summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2006-06-26 14:18:42 +0000
committerrussell <russell@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2006-06-26 14:18:42 +0000
commitb7d0f977e0f6bef02103a33aa9e5639d9ea3bfee (patch)
tree39ce673aeb318cc8b0234bb950a7f4f60b7df55c /configure.ac
parent65a9b51ba369276966ae2422d6df70b8e21aa106 (diff)
merge autoconf and menuselect support for zaptel
Happy birthday to me :) git-svn-id: http://svn.digium.com/svn/zaptel/trunk@1179 5390a7c7-147a-4af0-8ec9-7488f05a26cb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 53 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8f8cf94
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,53 @@
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+
+m4_define([ZAP_VERSION],
+ m4_bpatsubst(m4_esyscmd([build_tools/make_version .]),
+ [\([0-9.]*\)\(\w\|\W\)*],
+ [\1]))
+AC_INIT(zaptel, ZAP_VERSION, www.asterisk.org)
+
+# check existence of the package
+AC_CONFIG_SRCDIR([zaptel.c])
+
+AC_COPYRIGHT("Zaptel")
+AC_REVISION($Revision$)
+
+ac_default_prefix=/usr
+if test ${sysconfdir} = '${prefix}/etc'; then
+ sysconfdir=/etc
+fi
+if test ${mandir} = '${prefix}/man'; then
+ mandir=/usr/share/man
+fi
+
+if test ${localstatedir} = '${prefix}/var'; then
+ localstatedir=/var
+fi
+
+# This needs to be before any macros that use the C compiler
+AC_GNU_SOURCE
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AST_CHECK_GNU_MAKE
+
+AC_PATH_PROG([GREP], [grep], :)
+AC_PATH_PROG([SHELL], [sh], :)
+AC_PATH_PROG([LN], [ln], :)
+
+AC_LANG(C)
+
+AST_EXT_LIB([curses], [initscr], [curses.h], [CURSES], [curses], [])
+AST_EXT_LIB([ncurses], [initscr], [curses.h], [NCURSES], [ncurses], [])
+AST_EXT_LIB([newt], [newtBell], [newt.h], [NEWT], [newt])
+
+AC_CONFIG_FILES([build_tools/menuselect-deps makeopts])
+AC_OUTPUT
+
+echo "*** Zaptel build successfully configured ***"
+