summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2006-11-01 19:04:02 +0000
committerrussell <russell@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2006-11-01 19:04:02 +0000
commitc5cffae7b33823d655bffd2f373f8df7c1caf71b (patch)
tree067fd4a7fc6dc31e749eb29884ce52187e54536c /configure.ac
parenteb709f4c16130f01f5cf2a8a140ba8753ae17fef (diff)
instead of setting HOSTCC and CC directly in the Makefile, use the information
provided by the configure script (issue #8055, tzafrir) git-svn-id: http://svn.digium.com/svn/zaptel/branches/1.4@1547 5390a7c7-147a-4af0-8ec9-7488f05a26cb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7fbf880..fea925c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,10 @@ AC_PROG_INSTALL
AC_PROG_LN_S
AST_CHECK_GNU_MAKE
+# Set the default value of HOSTCC from CC if --host was not provided:
+HOSTCC=${HOSTCC:=${CC}}
+AC_SUBST(HOSTCC)
+
AC_PATH_PROG([GREP], [grep], :)
AC_PATH_PROG([SHELL], [sh], :)
AC_PATH_PROG([LN], [ln], :)