summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authortzafrir <tzafrir@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2007-10-28 18:26:04 +0000
committertzafrir <tzafrir@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2007-10-28 18:26:04 +0000
commitf6b333c29926fba9141491d078c5bd0a85c83172 (patch)
treed2763f1026198221b8b456565dc2a9e1fbdbba89 /configure.ac
parent60514309c0a2edc2bbb9bca527e10ceeef0c5691 (diff)
Firmware object file building does not depend anymore on another object
to be linked into the same module. That dependency existed solely for checking target binary properties in make_firmware_object . Those properties are now checked in autoconf. git-svn-id: http://svn.digium.com/svn/zaptel/branches/1.4@3198 5390a7c7-147a-4af0-8ec9-7488f05a26cb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6ee7523..5ef2cbd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,14 @@ AC_PROG_INSTALL
AC_PROG_LN_S
AST_CHECK_GNU_MAKE
+test_obj=conftest.o
+AC_COMPILE_IFELSE(AC_LANG_SOURCE(),[
+ BDFNAME=`LANG=C objdump -f $test_obj | grep -e "$test_obj:" | sed "s/.*file format \(.*\)/\1/"`
+ BDFARCH=`LANG=C objdump -f $test_obj | grep -e "architecture:" | sed "s/.*ture: \(.*\),.*/\1/"`
+],[])
+AC_SUBST(BDFNAME)
+AC_SUBST(BDFARCH)
+
# Set the default value of HOSTCC from CC if --host was not provided:
HOSTCC=${HOSTCC:=${CC}}
AC_SUBST(HOSTCC)
@@ -116,8 +124,9 @@ esac
AC_SUBST(PPPD_VERSION)
-AC_CONFIG_FILES([build_tools/menuselect-deps makeopts])
+AC_CONFIG_FILES([build_tools/menuselect-deps makeopts build_tools/make_firmware_object])
AC_OUTPUT
+chmod a+x build_tools/make_firmware_object
AC_MSG_NOTICE(*** Zaptel build successfully configured ***)