summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f05619..6ee7523 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,21 @@ AST_EXT_LIB([ncurses], [initscr], [curses.h], [NCURSES], [ncurses], [])
AST_EXT_LIB([newt], [newtBell], [newt.h], [NEWT], [newt])
AST_EXT_LIB([usb], [usb_init], [usb.h], [USB], [libusb])
+AC_ARG_WITH(selinux,
+ [AS_HELP_STRING([--with-selinux],
+ [enable (with) / disable (without) SELinux])],
+ [USE_SELINUX=$withval],
+ [ if test ! -x /usr/sbin/sestatus; then
+ USE_SELINUX=no;
+ elif /usr/sbin/sestatus | grep "SELinux status:" | grep -q "enabled"; then
+ USE_SELINUX=yes
+ fi
+ ]
+)
+
+
+AC_SUBST(USE_SELINUX)
+
# for asciidoc before ver. 7, the backend must be stated explicitly:
ASCIIDOC='asciidoc'
asciidoc_ver=`asciidoc --version 2>&1 | awk '/^asciidoc /{print $2}' | cut -d. -f 1 | head -n 1`