summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJenkins2 <jenkins2@gerrit.asterisk.org>2018-01-16 09:52:45 -0600
committerGerrit Code Review <gerrit2@gerrit.digium.api>2018-01-16 09:52:45 -0600
commit2f392bedb3987ee3c587bd8b046299320b84d5c5 (patch)
tree0354ceb1c0234ec6899ad6775aef6d4b3886e59f /configure.ac
parentd677ff47ae04b14fd0c4c5eae2c2ee6926f9e49c (diff)
parent645297614e2d2d69156ec166b13cedeac12bd0df (diff)
Merge "BuildSystem: Resolve resolv.h not via Generic but Particular Header-Check."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f0a978ee4..f68338b2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -605,11 +605,16 @@ if test "$ac_cv_header_sys_wait_h" != "yes"; then
AC_MSG_ERROR([*** POSIX.1 compatible sys/wait.h is required.])
fi
+AC_HEADER_RESOLV
+if test "$ac_cv_header_resolv_h" != "yes"; then
+ AC_MSG_ERROR([*** resolv.h is required.])
+fi
+
# Check for headers that are unconditionally required on all platforms. Do not use
# this to check for headers that are only needed by modules.
AC_CHECK_HEADERS([ \
arpa/nameser.h assert.h ctype.h dlfcn.h errno.h fcntl.h float.h grp.h \
- inttypes.h limits.h locale.h math.h pwd.h netinet/in.h regex.h resolv.h \
+ inttypes.h limits.h locale.h math.h pwd.h netinet/in.h regex.h \
sched.h stdarg.h stdint.h stdio.h stdlib.h string.h syslog.h \
sys/file.h sys/ioctl.h sys/param.h sys/resource.h sys/socket.h sys/stat.h \
sys/time.h sys/types.h sys/un.h \