summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJenkins2 <jenkins2@gerrit.asterisk.org>2018-03-13 18:17:22 -0500
committerGerrit Code Review <gerrit2@gerrit.digium.api>2018-03-13 18:17:22 -0500
commit4c0361f4f020ede21c1cbaac65c6e926f75d0983 (patch)
treeae07be9180a2b71aab1e5d982029d72e50cc92fc /configure.ac
parent200f7c520c679c85c001705eac57d3480649ae17 (diff)
parent75cebc3e71560e080c7157882583652684a3d720 (diff)
Merge "BuildSystem: Re-check for another UUID library only when previous check failed."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 13 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 47d26e298..1895c4185 100644
--- a/configure.ac
+++ b/configure.ac
@@ -638,20 +638,23 @@ AC_SUBST(EDITLINE_LIB)
# * -le2fs-uuid on OpenBSD
# * in libsystem on OS X
AST_EXT_LIB_CHECK([LIBUUID], [uuid], [uuid_generate_random], [uuid/uuid.h], [])
-AST_EXT_LIB_CHECK([E2FSUUID], [e2fs-uuid], [uuid_generate_random], [uuid/uuid.h], [])
-AC_CHECK_FUNCS([uuid_generate_random], [SYSUUID=true], [SYSUUID=""])
-
if test "x$LIBUUID_LIB" != "x" ; then
UUID_INCLUDE="$LIBUUID_INCLUDE"
UUID_LIB="$LIBUUID_LIB"
-elif test "x$E2FSUUID_LIB" != "x" ; then
- UUID_INCLUDE="$E2FSUUID_INCLUDE"
- UUID_LIB="$E2FSUUID_LIB"
-elif test "x$SYSUUID" != "x" ; then
- UUID_INCLUDE=""
- UUID_LIB=""
else
- AC_MSG_ERROR([*** uuid support not found (this typically means the uuid development package is missing)])
+ AST_EXT_LIB_CHECK([E2FSUUID], [e2fs-uuid], [uuid_generate_random], [uuid/uuid.h], [])
+ if test "x$E2FSUUID_LIB" != "x" ; then
+ UUID_INCLUDE="$E2FSUUID_INCLUDE"
+ UUID_LIB="$E2FSUUID_LIB"
+ else
+ AC_CHECK_FUNCS([uuid_generate_random], [SYSUUID=true], [SYSUUID=""])
+ if test "x$SYSUUID" != "x" ; then
+ UUID_INCLUDE=""
+ UUID_LIB=""
+ else
+ AC_MSG_ERROR([*** uuid support not found (this typically means the uuid development package is missing)])
+ fi
+ fi
fi
AC_SUBST(UUID_INCLUDE)
AC_SUBST(UUID_LIB)