summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJenkins2 <jenkins2@gerrit.asterisk.org>2018-02-16 08:02:30 -0600
committerGerrit Code Review <gerrit2@gerrit.digium.api>2018-02-16 08:02:30 -0600
commitbb723711a6cd9adacf9dcd3c3e98e595629b310b (patch)
tree127ac37d681d900b602724236caf3f077124e2f8 /configure.ac
parent062a83d5f8306d22ea4167ef418a893fdf83ea2b (diff)
parent2c814afb861d08fbc9a38b59b1814c3f4160e8e7 (diff)
Merge "BuildSystem: Enable system provided libedit on OpenBSD."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2029917f9..96210f203 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1575,12 +1575,15 @@ if test "${USE_ILBC}" != "no"; then
fi
AST_PKG_CONFIG_CHECK(LIBEDIT, libedit)
-AST_C_COMPILE_CHECK([LIBEDIT_IS_UNICODE], [el_rfunc_t *callback;], [histedit.h], [], [Testing for libedit unicode support])
-
+if test "${PBX_LIBEDIT}" != 1; then
+ # some platforms do not list libedit via pkg-config, for example OpenBSD 6.2
+ AST_EXT_LIB_CHECK([LIBEDIT], [edit], [history_init], [histedit.h], [-ltermcap])
+fi
if test "${PBX_LIBEDIT}" != 1; then
AC_MSG_ERROR(*** Please install the 'libedit' development package.)
exit 1
fi
+AST_C_COMPILE_CHECK([LIBEDIT_IS_UNICODE], [el_rfunc_t *callback;], [histedit.h], [], [Testing for libedit unicode support])
AST_EXT_LIB_CHECK([ICONV], [iconv], [iconv_open], [iconv.h])
# GNU libiconv #define's iconv_open to libiconv_open, so we need to search for that symbol